Details

LUFTRAUSERS is an arcade-style shooter game where players can choose from over 125 combinations of weapons, bodies, and propulsion systems to battle enemy fighter planes, battleships, submarines, and rival aces for glory, honor, and high scores. The game offers bold aerial combat with challenging gameplay, customizable rausers, daring missions, and the opportunity to unlock achievements.

List of Features:
  • Choose from over 125 combinations of weapons, bodies, and propulsion systems
  • Battle enemy fighter planes, battleships, submarines, and rival aces
  • Customizable rausers
  • Daring missions
  • Unlock achievements
Who should buy it?

LUFTRAUSERS is suitable for elite rauser pilots who want to become the most legendary. If you enjoy arcade-style shooter games with customizable elements, challenging gameplay, and the opportunity to unlock achievements, then LUFTRAUSERS is the game for you.

More Information
SKU LUFTR-PC-001
Redeem On Steam
Delivery Time Instant
Region Global
Developer Vlambeer
Publisher
Genre Action, Indie, Simulation
Languages
  • English
Release Date Mar 19, 2014
Age Rating
Minimum

OS: Windows XP
Processor: 1.2Ghz+
Memory: 1024 MB RAM
Graphics: OpenGL 2.1 compatibale + 256MB Video
Storage: 200 MB available space

Minimum

OS: OSX 10.8+
Processor: 1.2Ghz+
Memory: 1024 MB RAM
Graphics: OpenGL 2.1 compatibale + 256MB Video
Storage: 200 MB available space

Minimum

Processor: 1.2Ghz+
Memory: 1024 MB RAM
Graphics: OpenGL 2.1 compatibale + 256MB Video
Storage: 200 MB available space

Reviews
Your review
LUFTRAUSERS
  • Competitively Priced & No Hidden Fees
    We are committed to providing excellent service while helping you save money, and we believe in complete transparency. Rest assured, there are no hidden fees when you shop with us.
  • Customer Support 7 Days a Week
    Our dedicated email support team is here to assist you every day of the week, ensuring prompt assistance whenever you need it.
  • Instant Delivery on Digital Items
    Enjoy immediate access to your purchased keys, with 99% of deliveries available instantly upon purchase.
More from Devolver Digital

LUFTRAUSERS

Be the first to review this product
LUFTRAUSERS allows elite pilots to battle foes in customizable rausers. Choose from 125+ weapons, bodies, and propulsion systems for glory and high scores.
Notice

This product is not compatible with macOS 10.15 Catalina or above.

More Information
SKU LUFTR-PC-001
Redeem On Steam
Delivery Time Instant
Region Global
Developer Vlambeer
Publisher
Genre Action, Indie, Simulation
Languages
  • English
Release Date Mar 19, 2014
Age Rating
Minimum

OS: Windows XP
Processor: 1.2Ghz+
Memory: 1024 MB RAM
Graphics: OpenGL 2.1 compatibale + 256MB Video
Storage: 200 MB available space

Minimum

OS: OSX 10.8+
Processor: 1.2Ghz+
Memory: 1024 MB RAM
Graphics: OpenGL 2.1 compatibale + 256MB Video
Storage: 200 MB available space

Minimum

Processor: 1.2Ghz+
Memory: 1024 MB RAM
Graphics: OpenGL 2.1 compatibale + 256MB Video
Storage: 200 MB available space

  • Competitively Priced & No Hidden Fees
    We are committed to providing excellent service while helping you save money, and we believe in complete transparency. Rest assured, there are no hidden fees when you shop with us.
  • Customer Support 7 Days a Week
    Our dedicated email support team is here to assist you every day of the week, ensuring prompt assistance whenever you need it.
  • Instant Delivery on Digital Items
    Enjoy immediate access to your purchased keys, with 99% of deliveries available instantly upon purchase.

LUFTRAUSERS

Be the first to review this product
LUFTRAUSERS allows elite pilots to battle foes in customizable rausers. Choose from 125+ weapons, bodies, and propulsion systems for glory and high scores.
Notice

This product is not compatible with macOS 10.15 Catalina or above.

Download code via email
Redeem on
$6.99
-30% $9.99
Activates in United States Please note a virtual private network (VPN) can hide a user's internal protocol address (IP address) and block their location and browser history.
Notice

This product is not compatible with macOS 10.15 Catalina or above.